Ce matin j’ai peur.

Depuis que je me suis levé ce matin, j’ai peur. Une peur qui rend les tâches les plus simples quasi impossibles tellement elle hante mon esprit. Ce n’est pas pour moi que j’ai peur, Frank the Tank, Tigerblood, amène là ta gang, insérez ici un cliché du (relativement) jeune homme qui se croit invincible. J’ai peur pour ma mère, j’ai peur pour mon père (listés ici en ordre alphabétique, pas de chicane vous deux!).

Je suis le plus jeune de ma famille et j’ai déjà 30 ans, donc vous n’avez pas besoin d’être des génies de mathématiques pour comprendre qu’ils ne sont plus aussi en forme qu’ils l’ont déjà été. Mes parents ont toujours été parmi les contestataires de ce monde. J’ai participé à ma première manifestation avant même de pouvoir marcher! Pourtant, ils n’ont jamais fait partie des casseurs. Du moins pas depuis mon vivant. Après tout, je ne prétends pas tout savoir de leur vie. Mes parents sont de ces naïfs qui pensent que le système peut fonctionner si on y met du sien, de ceux qui se disent que nous avons le pouvoir de changer les choses qui vont mal. Ils sont donc très régulièrement présents dans des manifestations de toutes sortes. Ils refusent de se taire et c’est une des nombreuses raisons pour lesquelles je les aime.

 

J’ai peur que la police leur fasse du mal.

 

C’est un non-sens total et complet. Mes parents sont tout ce qu’il y a de plus pacifiques, ils ne feraient pas de mal à une mouche. Pourtant, après avoir vu les images et entendu les reportages à propos de la manifestation d’hier, c’est la seule chose à laquelle je suis capable de penser. Le même scénario se répète sans cesse dans ma tête, mes parents décident d’aller à une autre manifestation, ils veulent soutenir la jeunesse et faire entendre leur voix au gouvernement. Ils vont marcher dans la rue comme ils l’ont fait des dizaines, voire des centaines de fois auparavant, mais cette fois-ci c’est différent. Cette fois-ci au bout de quelque temps la police décide que ça suffit et sans avertissement quelconque elle prend la foule d’assaut et mes parents sont en plein centre. C’est là que ma vision s’embrouille, je vois des gens qui courent dans tous les sens en panique et mes parents qui cherchent à trouver un endroit où ils pourraient être en sécurité. Mais j’ai peur qu’ils ne soient pas capables de le trouver.

Pour la première fois de ma vie, j’ai peur pour mes parents à la simple pensée qu’ils tentent de se faire entendre comme ils l’ont si souvent fait. Je me sens choyé de ne pas avoir d’enfant en âge de manifester, en fait de ne pas avoir d’enfant du tout. Si cette peur me hante pour mes parents je n’ose pas penser ce que ce serait pour mes enfants. J’ai une petite pensée pour les parents de ceux qui sont dans la rue et encore une fois, j’ai peur. Si les forces de l’ordre voulaient réellement faire régner l’ordre, ils tenteraient de faire disperser ceux qui ne sont pas là pour faire de la casse avant de charger la foule. Je n’arrive pas à comprendre comment attaquer un rassemblement de gens très majoritairement pacifiques peut sembler être une réponse adéquate au peu de grabuge qu’il y a eu. Mais avant tout ça, j’ai peur pour ma mère et mon père.

J’implore donc ici les forces de l’ordre de tout le Québec de ne pas tomber dans la facilité et de ne pas assumer que toute personne qui manifeste est leur ennemi, est un fauteur de trouble. Je les implore de faire l’effort du discernement. Je les implore de m’aider à arrêter d’avoir peur.

QNAP, je t’aime pas

On va mettre quelque chose au clair avant de commencer. Je parle ici de la gamme « Enterprise » des produits QNAP. Ils font peut-être de très bon NAS pour le commun des mortels mais je n’ai jamais eu la « chance » d’en essayer un.

J’ai eu à me battre avec 2 QNAP 809 au cours des dernières semaines. Un me disait qu’un de ses disques était mort et l’autre refusait d’afficher son interface web. Les 2 problèmes me semblaient plutôt simples à corriger mais j’allais, malheureusement, être surpris.

Première surprise, QNAP ne vend pas et ne supporte pas les disques dans ses unités de stockage. Dans le marché du consommateur, ou même dans celui du « prosumer » qui se veut un mi-chemin entre le pro et le particulier, c’est relativement commun. Pour un produit d’entreprise c’est passablement plus rare, surtout qu’ils peuvent charger le gros prix pour le support et que bien des compagnies n’y verront que du feu. J’ai survécus à pire me dis-je et je renvois le disque chez Seagate, aucun stress puisque l’unité fonctionne en RAID 6!

Deuxième surprise, quand je me connecte en SSH au 2e je remarque qu’il n’y a pas d’interface de gestion « out-of-band ». La boîte n’est qu’un ordinateur avec un Linux modifié et 2 interfaces réseaux. Donc quand on éteint le NAS, plus moyen de s’y connecter. Encore une fois, si c’était mon petit NAS à la maison ça irait, mais comme je dois traverser 4 portes barrées pour passer de mon bureau à la salle de serveurs, c’est une autre histoire!

Je suis un éternel optimiste, malgré ce que certains puissent en dire, donc je me remonte le moral en me disant qu’un Linux un peu modifié sera facile à diagnostiquer. Je trouve quelques services se nommant *httpd, j’essaie donc de les redémarrer. Un d’entre eux me dit ne pas trouver certains fichiers essentiels à son bon fonctionnement. Vérification sur le 1er QNAP, ils y sont effectivement présents! On arrête les services http, on copie les fichiers et on redémarre les services. Plus de message d’erreur, victoire… ou pas! Le service web n’affiche toujours aucun contenu.

Je prends une pause en me disant que la nuit porte conseil. Je peux prendre mon temps, ce n’est que l’interface web après tout!

Le lendemain je reçois le disque de remplacement. Je l’installe sans problème, mais malheureusement l’unité ne voit toujours aucun disque à cette position. Je vérifie les connections à l’arrière du disque, tout semble parfait. Je fouille dans les logs de l’unité pour découvrir que celle-ci pense que le disque qui était supposément défectueux aurait été retiré de l’unité avant d’être déclaré mort. Impossible, ils sont barrés en place! Je commence à me méfier de ces bêtes.

Je décide d’appliquer la méthode de diagnostic de The IT Crowd: Have you tried to turn it off and on again? À ma grande surprise l’unité voit le disque et commence sa reconstruction de données. Aucune mention de quoi que ce soit d’anormal dans les logs.*

J’ai soudain une idée pour mon 2e problème. J’efface tous les fichiers que j’ai moi-même copié du 1er QNAP au 2e lors de ma tentative précédente et je redémarre la bête. Comme par magie l’interface web fonctionne à nouveau! Pourtant les fichiers manquants n’y sont toujours pas, j’ai vérifié.

Bref, le 1er avait un port qui ne voyait plus ce qui y était connecté et le 2e refusait d’afficher l’interface web même si on redémarrait ses services web. Les 2 corrigés en redémarrant. Pour une unité de stockage c’est un peu troublant.

QNAP, je t’aime pas!!!!

*J’ai découvert par la suite qu’une mise à jour du firmware corrige le bug des disques fantômes.

Corriger des erreurs de mémoire sur un blade X6270M2

J’ai découvert un bug vraiment louche dans les BIOS des blades X6270M2 d’Oracle. Parfois il y a un festival d’erreurs mémoire qui se produisent toujours à la même position peu importe quelle barette de mémoire s’y trouve.

On a beau essayé de changer la mémoire de place, l’erreur semble toujours être détectée au même endroit. Pire encore, si on change la carte mère l’erreur peu persister!

Source du problème? Une mauvaise gestion des modes d’alimentation du processeur par le BIOS.

Correctif:

1 Allez dans le BIOS et appuyez sur F4 pour activer le mode « expert »
2 Allez dans la section CPU du 2e onglet
3 Désactivez l’option « C6 State » (vers la fin de la liste des options)
4 Configurez l’option « C state package limit setting » à « C3″

Pourquoi? Aucune idée. Même l’ingénieur d’Oracle qui me l’a dit ne savait pas d’où ça sortait.

Dans les versions récentes du firmware (r66959 et plus si ma mémoire est bonne) le bug a disparus. Les options à modifié aussi remarquez ;)

Remettre le mot de passe d’un T5220/T5420 à sa valeur par defaut

B’jour, les instructions sont en anglais, je vais les traduires un jour, quand je repasserai par ici:

1 Initialize and power down system.
2 Use ESD precautions.
3 Remove all cables.
4 Slide server out of rack to its fullest extent.
5 Remove top cover.
6 Remove PCI back panel cross beam

T5420
7 Remove leftmost PCI/XAUI riser. (closest to battery)
8 Using PCB jumper (not supplied) connect pins 1 & 2 on J10401 (next to ALOM module)

T5220
7 Remove middle PCI/XAUI riser.
8 Using PCB jumper (not supplied) connect pins 1 & 2 on J6801.

9 Reconnect serial terminal.
10 Reconnect power cable(s)
11 Switch KVM monitor to Serial output for TMAN being restored.
12 Watch ILOM boot process and wait for login prompt.
13 When login prompt appears wait an additional 60 seconds ? at least.

T5420
14 Login as root using password ?changeme?.

T5220
14 Login as default, press the physical presence button when prompted and use the password defaultpassword

15 When prompted change password.
16 Remove power cables.
17 Remove PCB jumper (installed above).
18 Replace PCI/XAUI riser.
19 Replace PCI back panel cross beam.
20 Replace top cover.
21 Slide server back into rack.
22 Reconnect all cables.
23 After ILOM has finished booting push power button on front panel. You should feel a slight click. You will also see a flurry of lights and hear some whirring indicating hard drive activity.

Voilà! Oui utiliser un jumper ça fait 1990 mais que voulez-vous, c’est comme ça!